Marcus L. Rowland (ffutures) wrote,
Marcus L. Rowland
ffutures

Google earth stupidity

Google earth (the mac version) has now started to insist that the latest version is a "mandatory upgrade" and won't let me run the old version. The new version won't run on mac OS-X 10.3.9, it needs 10.4... And I'm really not going to pay a hundred pounds or more for an operating system I don't otherwise need. I'll try complaining on the forums again, but I suspect it won't do much good.

Later: On checking the Mac forums for Google Earth it looks like this is a bug with the automatic update program which Google are trying to fix.

VERY later: Turns out that shutting down the Mac and restarting appears to fix this. So far, anyway.
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

  • 5 comments